using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(longword1|longword2)\b.*?\b(?!\1\b)(?1)\b";
string input = @"A longword1 B longword2 C
^-------------------^
A longword2 B longword1 C
^-------------------^
while these shouldn't:
A longword1 B longword1 C
A longword2 B longword2 C
A longword1 B
A longword2 C";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}