re = /\b(longword1|longword2)\b.*?\b(?!\1\b)(?1)\b/m
str = 'A longword1 B longword2 C
^-------------------^
A longword2 B longword1 C
^-------------------^
while these shouldn\'t:
A longword1 B longword1 C
A longword2 B longword2 C
A longword1 B
A longword2 C'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end