$re = '/\b(longword1|longword2)\b.*?\b(?!\1\b)(?1)\b/m';
$str = 'A longword1 B longword2 C
^-------------------^
A longword2 B longword1 C
^-------------------^
while these shouldn\'t:
A longword1 B longword1 C
A longword2 B longword2 C
A longword1 B
A longword2 C';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);