import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(longword1|longword2)\\b.*?\\b(?!\\1\\b)(?1)\\b";
final String string = "A longword1 B longword2 C\n"
+ " ^-------------------^\n\n"
+ "A longword2 B longword1 C\n"
+ " ^-------------------^\n"
+ "while these shouldn't:\n\n"
+ "A longword1 B longword1 C\n"
+ "A longword2 B longword2 C\n"
+ "A longword1 B\n"
+ "A longword2 C";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}