#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[<>]?=?\d+(?:\.\d+)?|\d+(?:\.\d+)?-\d+(?:\.\d+)?)$"
Local $sString = "Should match:" & @CRLF & _
">1" & @CRLF & _
"<9" & @CRLF & _
">=99" & @CRLF & _
"<=123123.134" & @CRLF & _
"1-2" & @CRLF & _
"44.421-234.123" & @CRLF & _
"123" & @CRLF & _
"123.123" & @CRLF & _
"0.123" & @CRLF & _
"" & @CRLF & _
"Shouldn't match:" & @CRLF & _
"123." & @CRLF & _
".123" & @CRLF & _
"=<123" & @CRLF & _
"=>234" & @CRLF & _
"sdf" & @CRLF & _
"sdf.sdf" & @CRLF & _
"123.sdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")