// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[<>]?=?\d+(?:\.\d+)?|\d+(?:\.\d+)?-\d+(?:\.\d+)?)$").unwrap();
let string = "Should match:
>1
<9
>=99
<=123123.134
1-2
44.421-234.123
123
123.123
0.123
Shouldn't match:
123.
.123
=<123
=>234
sdf
sdf.sdf
123.sdf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}