import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[<>]?=?\\d+(?:\\.\\d+)?|\\d+(?:\\.\\d+)?-\\d+(?:\\.\\d+)?)$";
final String string = "Should match:\n"
+ ">1\n"
+ "<9\n"
+ ">=99\n"
+ "<=123123.134\n"
+ "1-2\n"
+ "44.421-234.123\n"
+ "123\n"
+ "123.123\n"
+ "0.123\n\n"
+ "Shouldn't match:\n"
+ "123.\n"
+ ".123\n"
+ "=<123\n"
+ "=>234\n"
+ "sdf\n"
+ "sdf.sdf\n"
+ "123.sdf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}