package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[<>]?=?\d+(?:\.\d+)?|\d+(?:\.\d+)?-\d+(?:\.\d+)?)$`)
var str = `Should match:
>1
<9
>=99
<=123123.134
1-2
44.421-234.123
123
123.123
0.123
Shouldn't match:
123.
.123
=<123
=>234
sdf
sdf.sdf
123.sdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}