re = /^(?:[<>]?=?\d+(?:\.\d+)?|\d+(?:\.\d+)?-\d+(?:\.\d+)?)$/m
str = 'Should match:
>1
<9
>=99
<=123123.134
1-2
44.421-234.123
123
123.123
0.123
Shouldn\'t match:
123.
.123
=<123
=>234
sdf
sdf.sdf
123.sdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end