const regex = /^(?:[<>]?=?\d+(?:\.\d+)?|\d+(?:\.\d+)?-\d+(?:\.\d+)?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[<>]?=?\\d+(?:\\.\\d+)?|\\d+(?:\\.\\d+)?-\\d+(?:\\.\\d+)?)$', 'gm')
const str = `Should match:
>1
<9
>=99
<=123123.134
1-2
44.421-234.123
123
123.123
0.123
Shouldn't match:
123.
.123
=<123
=>234
sdf
sdf.sdf
123.sdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}