#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https://docs\.python\.org/\d/[^#]*$"
Local $sString = "https://docs.python.org/3/library/foo.html" & @CRLF & _
"https://docs.python.org/3/reference/foo.html#some_hash" & @CRLF & _
"https://docs.python.org/3.6/using/foo.html" & @CRLF & _
"https://docs.python.org/3/#extension1" & @CRLF & _
"https://docs.python.org/2/library/bar.html" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")