const regex = new RegExp('^https://docs\\.python\\.org/\\d/[^#]*$', 'mg')
const str = `https://docs.python.org/3/library/foo.html
https://docs.python.org/3/reference/foo.html#some_hash
https://docs.python.org/3.6/using/foo.html
https://docs.python.org/3/#extension1
https://docs.python.org/2/library/bar.html
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}