// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^https://docs\.python\.org/\d/[^#]*$").unwrap();
let string = "https://docs.python.org/3/library/foo.html
https://docs.python.org/3/reference/foo.html#some_hash
https://docs.python.org/3.6/using/foo.html
https://docs.python.org/3/#extension1
https://docs.python.org/2/library/bar.html
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}