import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https://docs\\.python\\.org/\\d/[^#]*$";
final String string = "https://docs.python.org/3/library/foo.html\n"
+ "https://docs.python.org/3/reference/foo.html#some_hash\n"
+ "https://docs.python.org/3.6/using/foo.html\n"
+ "https://docs.python.org/3/#extension1\n"
+ "https://docs.python.org/2/library/bar.html\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}