$re = '/^https://docs\.python\.org/\d/[^#]*$/m';
$str = 'https://docs.python.org/3/library/foo.html
https://docs.python.org/3/reference/foo.html#some_hash
https://docs.python.org/3.6/using/foo.html
https://docs.python.org/3/#extension1
https://docs.python.org/2/library/bar.html
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);