using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:[^,]*,){8})""?([^,""]*)";
string input = @"Home_TE,-2.8,1,""-"",-,-,-,1,""-"",-,-,-,""-"",1,-,""-"",""-"",-,-,MIL_TT
Home_TE,-2.8,1,""-"",-,-,-,1,123,-,-,-,""-"",1,-,""-"",""-"",-,-,MIL_TT
Home_TE,-2.8,1,""-"",-,-,-,1,456,-,-,-,""-"",1,-,""-"",""-"",-,-,MIL_TT";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}