package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:[^,]*,){8})"?([^,"]*)`)
var str = `Home_TE,-2.8,1,"-",-,-,-,1,"-",-,-,-,"-",1,-,"-","-",-,-,MIL_TT
Home_TE,-2.8,1,"-",-,-,-,1,123,-,-,-,"-",1,-,"-","-",-,-,MIL_TT
Home_TE,-2.8,1,"-",-,-,-,1,456,-,-,-,"-",1,-,"-","-",-,-,MIL_TT`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}