$re = '/^(?:(?:[^,]*,){8})"?([^,"]*)/m';
$str = 'Home_TE,-2.8,1,"-",-,-,-,1,"-",-,-,-,"-",1,-,"-","-",-,-,MIL_TT
Home_TE,-2.8,1,"-",-,-,-,1,123,-,-,-,"-",1,-,"-","-",-,-,MIL_TT
Home_TE,-2.8,1,"-",-,-,-,1,456,-,-,-,"-",1,-,"-","-",-,-,MIL_TT';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);