import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:[^,]*,){8})\"?([^,\"]*)";
final String string = "Home_TE,-2.8,1,\"-\",-,-,-,1,\"-\",-,-,-,\"-\",1,-,\"-\",\"-\",-,-,MIL_TT\n"
+ "Home_TE,-2.8,1,\"-\",-,-,-,1,123,-,-,-,\"-\",1,-,\"-\",\"-\",-,-,MIL_TT\n"
+ "Home_TE,-2.8,1,\"-\",-,-,-,1,456,-,-,-,\"-\",1,-,\"-\",\"-\",-,-,MIL_TT";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}