const regex = /^(?:(?:[^,]*,){8})"?([^,"]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:[^,]*,){8})"?([^,"]*)', 'gm')
const str = `Home_TE,-2.8,1,"-",-,-,-,1,"-",-,-,-,"-",1,-,"-","-",-,-,MIL_TT
Home_TE,-2.8,1,"-",-,-,-,1,123,-,-,-,"-",1,-,"-","-",-,-,MIL_TT
Home_TE,-2.8,1,"-",-,-,-,1,456,-,-,-,"-",1,-,"-","-",-,-,MIL_TT`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}