package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*([\S]+)$`)
var str = `I would like to extract the last word of each line using regex. Most of the last words are built up like this:
alkj;asdf ;lkjasd f;lkj sjdjd AAAAB3NzaCLkc3M
asdf ajksdf ;lakjsdf ;lkjasdfAAAB3NzaCl/Ezfl
asdf sjadf asdkfj kjasdfAAAB3Nza/ClBAm+4lj
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}