import re
regex = re.compile(r"\s*([\S]+)$", flags=re.MULTILINE)
test_str = ("I would like to extract the last word of each line using regex. Most of the last words are built up like this:\n\n"
"alkj;asdf ;lkjasd f;lkj sjdjd AAAAB3NzaCLkc3M\n\n"
"asdf ajksdf ;lakjsdf ;lkjasdfAAAB3NzaCl/Ezfl\n\n"
"asdf sjadf asdkfj kjasdfAAAB3Nza/ClBAm+4lj\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")