use strict;
my $str = 'I would like to extract the last word of each line using regex. Most of the last words are built up like this:
alkj;asdf ;lkjasd f;lkj sjdjd AAAAB3NzaCLkc3M
asdf ajksdf ;lakjsdf ;lkjasdfAAAB3NzaCl/Ezfl
asdf sjadf asdkfj kjasdfAAAB3Nza/ClBAm+4lj
';
my $regex = qr/\s*([\S]+)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}