import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*([\\S]+)$";
final String string = "I would like to extract the last word of each line using regex. Most of the last words are built up like this:\n\n"
+ "alkj;asdf ;lkjasd f;lkj sjdjd AAAAB3NzaCLkc3M\n\n"
+ "asdf ajksdf ;lakjsdf ;lkjasdfAAAB3NzaCl/Ezfl\n\n"
+ "asdf sjadf asdkfj kjasdfAAAB3Nza/ClBAm+4lj\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}