// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s*([\S]+)$").unwrap();
let string = "I would like to extract the last word of each line using regex. Most of the last words are built up like this:
alkj;asdf ;lkjasd f;lkj sjdjd AAAAB3NzaCLkc3M
asdf ajksdf ;lakjsdf ;lkjasdfAAAB3NzaCl/Ezfl
asdf sjadf asdkfj kjasdfAAAB3Nza/ClBAm+4lj
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}