#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?u)(.*?)§\\n(?=.*\\n)"
Local $sString = "abc§\ndef§\nghi\n" & @CRLF & _
"abc§\ndef§\nghi§\n" & @CRLF & _
"abc§\ndef§\nghi§§\n"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)