const regex = /(.*?)§\\n(?=.*\\n)/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?)§\\\\n(?=.*\\\\n)', 'gu')
const str = `abc§\\ndef§\\nghi\\n
abc§\\ndef§\\nghi§\\n
abc§\\ndef§\\nghi§§\\n`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);