import re
regex = re.compile(r"(.*?)§\\n(?=.*\\n)", flags=re.UNICODE)
test_str = ("abc§\\ndef§\\nghi\\n\n"
"abc§\\ndef§\\nghi§\\n\n"
"abc§\\ndef§\\nghi§§\\n")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)