$re = '/(.*?)§\\\\n(?=.*\\\\n)/u';
$str = 'abc§\\ndef§\\nghi\\n
abc§\\ndef§\\nghi§\\n
abc§\\ndef§\\nghi§§\\n';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;