# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?:(t)hru|rough)\b/$1hrough/gi;t' <<< "rough"