import Foundation
let pattern = #"\b(?:(t)hru|rough)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"rough"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1hrough"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)