import re
regex = re.compile(r"\b(?:(t)hru|rough)\b", flags=re.IGNORECASE)
test_str = "rough"
subst = "$1hrough"
result = regex.sub(subst, test_str)
if result:
print(result)