$re = '/\b(?:(t)hru|rough)\b/i';
$str = 'rough';
$subst = "$1hrough";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;