use strict;
my $str = 'rough';
my $regex = qr/\b(?:(t)hru|rough)\b/ip;
my $subst = '$1hrough';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";