#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x) "[^"\\]*(?s:\\.[^"\\]*)*+"" & @CRLF & _
" (*SKIP)(*F)" & @CRLF & _
"|" & @CRLF & _
" /" & @CRLF & _
" (?:" & @CRLF & _
" / .*" & @CRLF & _
" |" & @CRLF & _
" \* [^*]* (?: \*+(?!/) [^*]* )*+ (?:\*/)?" & @CRLF & _
" )"
Local $sString = "/* toto****to ****/ /****/ " & @CRLF & _
"char * foo = "//don't\" // remove" " // really please don't"; // But remove this ha ha! // along with this!" & @CRLF & _
"" & @CRLF & _
"char *bad_regex_strategy = "\"good luck\" // \"counting the \"quotes\"" "//\"//"; // \"ha""" \" " \" ha ha\" ha /// "\;"ha'" & @CRLF & _
"/*" & @CRLF & _
"and then imagine a copy of that entire line commented out on the next line of source." & @CRLF & _
"I'd question the entire task and see if there isn't a C source manipulation library you should be using instead. ?" & @CRLF & _
" BaseZen 2 hours ago Is it? So when I have the choise between doing this by regex or final state machine, u recommend the FSM, right?" & @CRLF & _
" :/ ? user3457394 2 hours ago"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")