use strict;
my $str = '/* toto****to ****/ /****/
char * foo = "//don\'t\\" // remove" " // really please don\'t"; // But remove this ha ha! // along with this!
char *bad_regex_strategy = "\\"good luck\\" // \\"counting the \\"quotes\\"" "//\\"//"; // \\"ha""" \\" " \\" ha ha\\" ha /// "\\;"ha\'
/*
and then imagine a copy of that entire line commented out on the next line of source.
I\'d question the entire task and see if there isn\'t a C source manipulation library you should be using instead. ?
BaseZen 2 hours ago Is it? So when I have the choise between doing this by regex or final state machine, u recommend the FSM, right?
:/ ? user3457394 2 hours ago';
my $regex = qr~ "[^"\\]*(?s:\\.[^"\\]*)*+"
(*SKIP)(*F)
|
/
(?:
/ .*
|
\* [^*]* (?: \*+(?!/) [^*]* )*+ (?:\*/)?
)~xp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}