$re = '~ "[^"\\\\]*(?s:\\\\.[^"\\\\]*)*+"
(*SKIP)(*F)
|
/
(?:
/ .*
|
\* [^*]* (?: \*+(?!/) [^*]* )*+ (?:\*/)?
)~x';
$str = '/* toto****to ****/ /****/
char * foo = "//don\'t\\" // remove" " // really please don\'t"; // But remove this ha ha! // along with this!
char *bad_regex_strategy = "\\"good luck\\" // \\"counting the \\"quotes\\"" "//\\"//"; // \\"ha""" \\" " \\" ha ha\\" ha /// "\\;"ha\'
/*
and then imagine a copy of that entire line commented out on the next line of source.
I\'d question the entire task and see if there isn\'t a C source manipulation library you should be using instead. ?
BaseZen 2 hours ago Is it? So when I have the choise between doing this by regex or final state machine, u recommend the FSM, right?
:/ ? user3457394 2 hours ago';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);