// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?x) "[^"\\]*(?s:\\.[^"\\]*)*+"
(*SKIP)(*F)
|
/
(?:
/ .*
|
\* [^*]* (?: \*+(?!/) [^*]* )*+ (?:\*/)?
)"#).unwrap();
let string = "/* toto****to ****/ /****/
char * foo = \"//don't\\\" // remove\" \" // really please don't\"; // But remove this ha ha! // along with this!
char *bad_regex_strategy = \"\\\"good luck\\\" // \\\"counting the \\\"quotes\\\"\" \"//\\\"//\"; // \\\"ha\"\"\" \\\" \" \\\" ha ha\\\" ha /// \"\\;\"ha'
/*
and then imagine a copy of that entire line commented out on the next line of source.
I'd question the entire task and see if there isn't a C source manipulation library you should be using instead. ?
BaseZen 2 hours ago Is it? So when I have the choise between doing this by regex or final state machine, u recommend the FSM, right?
:/ ? user3457394 2 hours ago";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}