import re
regex = re.compile(r"""
"[^"\\]*(?s:\\.[^"\\]*)*+"
(*SKIP)(*F)
|
/
(?:
/ .*
|
\* [^*]* (?: \*+(?!/) [^*]* )*+ (?:\*/)?
)
""", flags=re.VERBOSE)
test_str = ("/* toto****to ****/ /****/ \n"
"char * foo = \"//don't\\\" // remove\" \" // really please don't\"; // But remove this ha ha! // along with this!\n\n"
"char *bad_regex_strategy = \"\\\"good luck\\\" // \\\"counting the \\\"quotes\\\"\" \"//\\\"//\"; // \\\"ha\"\"\" \\\" \" \\\" ha ha\\\" ha /// \"\\;\"ha'\n"
"/*\n"
"and then imagine a copy of that entire line commented out on the next line of source.\n"
"I'd question the entire task and see if there isn't a C source manipulation library you should be using instead. ?\n"
" BaseZen 2 hours ago Is it? So when I have the choise between doing this by regex or final state machine, u recommend the FSM, right?\n"
" :/ ? user3457394 2 hours ago")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")