# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^Dr\b\.?\s*//gm;t' <<< "Fred Smith
Dr John Paul
Dr. Mary Ellen
Bill Driver
Draco Malfoy"