$re = '/^Dr\b\.?\s*/m';
$str = 'Fred Smith
Dr John Paul
Dr. Mary Ellen
Bill Driver
Draco Malfoy';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;