// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^Dr\b\.?\s*").unwrap();
let string = "Fred Smith
Dr John Paul
Dr. Mary Ellen
Bill Driver
Draco Malfoy";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}