const regex = /^Dr\b\.?\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Dr\\b\\.?\\s*', 'gm')
const str = `Fred Smith
Dr John Paul
Dr. Mary Ellen
Bill Driver
Draco Malfoy`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);