import re
regex = re.compile(r"^Dr\b\.?\s*", flags=re.MULTILINE)
test_str = ("Fred Smith\n"
"Dr John Paul\n"
"Dr. Mary Ellen\n"
"Bill Driver\n"
"Draco Malfoy")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)