#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^Dr\b\.?\s*"
Local $sString = "Fred Smith" & @CRLF & _
"Dr John Paul" & @CRLF & _
"Dr. Mary Ellen" & @CRLF & _
"Bill Driver" & @CRLF & _
"Draco Malfoy"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)