# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?:V4|V1|V6)\b,?//gm;t' <<< "V1,V2,V3,V4,V5,V6"