use strict;
my $str = 'V1,V2,V3,V4,V5,V6';
my $regex = qr/\b(?:V4|V1|V6)\b,?/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";