const regex = /\b(?:V4|V1|V6)\b,?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:V4|V1|V6)\\b,?', 'gm')
const str = `V1,V2,V3,V4,V5,V6`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);