import re
regex = re.compile(r"\b(?:V4|V1|V6)\b,?", flags=re.MULTILINE)
test_str = "V1,V2,V3,V4,V5,V6"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)