#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<td>(?:<a.*?>)?([^<]+)"
Local $sString = "<irrelevant things> " & @CRLF & _
" <tr id="myid"> " & @CRLF & _
" <td>Content</td> " & @CRLF & _
" </tr> " & @CRLF & _
"<irrelevant things again>" & @CRLF & _
"" & @CRLF & _
"<irrelevant things> " & @CRLF & _
" <tr id="myid"> " & @CRLF & _
" <td><a href="somewhere.com">Content</a></td> " & @CRLF & _
" </tr> " & @CRLF & _
"<irrelevant things again>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")